Idle control valve(stepper motor)

Anything to do with the 1200 'strada' series
Post Reply
MrWilson
Posts: 12
Joined: 21 Dec 2016 22:54
Location: Finland
Location: Finland

Idle control valve(stepper motor)

Post by MrWilson »

Hey! I have had temporarily stalling problem. It's been mostly in wet conditions, but always got better sooner or later. In the same time the motor got running some kind of rough. Now it didn't cure by itself, so I opened the airbox. There was quite a lot of dirt inside. Cleaned it and oiled the air filter. But I also tried to check the idle control valve. Tune ecu says that it can't test it. I tested it by taking off the hoses. Looks that the valve is almost all the time full open. I run the motor in different rews and the valve was open all the time. Only when cutting the ignition off it shuts the valve for a while. In the same time it makes a nasty rattle voice in the middle of it's move. Tried the bike driving without the valve, just blocked the hoses. Throttle was sharper in my opinion. Idle was a little lower, but stalling was not any worse without the valve. So, should the valve be shut or open when rewwing the motor?
User avatar
Will
Posts: 4
Joined: 29 Jun 2020 23:26
Location: Spain
Location: Barcelona
Contact:

Re: Idle control valve(stepper motor)

Post by Will »

Did you sort this out?
I've been getting a fair amount of backfiring, sometimes some coughing through the throttle bodies so I went over the exhaust and sealed it better (catalizer bracket had self-destructed so all was loose) and flashed the original map, all of which helped a lot, and tomorrow I'll see if it makes any difference putting clamps on the IAC tubes because they were pretty loose too, there could be air getting sucked through by those ginormous pistons on decel with throttle at just about nothing. Is there a way of dismantling the IAC valve to give it a proper clean out? I didn't want to break it! 2009 Scrambler ;)
augbjo2000
Posts: 10
Joined: 11 Jun 2021 13:40
Location: Norway

Re: Idle control valve(stepper motor)

Post by augbjo2000 »

I have also experienced that the 9 1/2 «dont like» rain :-). It is Running very Rough and backfiring and stalling when you go off the throttle.
It must be one of the sensors ( temperature ? ) or one of the others that dont like wet conditions

It must be one that is exposed for the weather - not inside the airfilter box - I have bought a new air temp sensor - will start with that one :-)
MickeyMoto
Posts: 1968
Joined: 22 Nov 2008 17:41
Location: Even further oop North

Re: Idle control valve(stepper motor)

Post by MickeyMoto »

Is the spark plug drain clear? If you check there is a hole in the head. Might be worth removing the coil and poking the hole, or even checking to see if the coil material is breaking down.
Post Reply